Symantec Backup Exec RALUS Linux Agent ///// Error

Dealing with Symantec is a complete nightmare and it’s more of a nightmare when you feel like you’ve have been held hostage by a product that does not have the support or the quality of code that it needs to be considered an ‘enterprise’ software solution. As you’ve already guessed, we are talking about Symantec Backup Exec 2010 R2.

I have had the RALUS/VRTSralus Linux Agent working just fine for months until what I suspect was a LiveUpdate patch which may have broken the Linux remote agent. The root cause of this particular issue is really unknown but has to do with the error listed below.

43bd9940 Sat Jul 30 01:48:19 2011 :
vx_stat_by_name: Getting stat of /backup/dir/home/user/build/emcgrab/tools/lite//////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
//////////////////////////////////ecc.sh
43bd9940 Sat Jul 30 01:48:19 2011 :
vx_get_link_target for /backup/dir/home/user/build/emcgrab/tools/lite//////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
///////////////////////////////////////////////////////////////////////////
/////////////////////////////////////////////////////////

After speaking with Symantec support and a bunch of go around over the telephone and emails, my team and I are lead to believe that Soft-link directories in Linux is causing the issue above. There is a known limitation with Backup Exec’s Linux agent which prevents paths being longer than 255 characters. I believe when the agent encounters a soft-linked directory, the agent fails and appends trailing slashes in an infinite loop until it hits the 255 character limit which causes the remote agent to crash. The backup job then terminates early and forces the job to Verify if you job is configured to do so.

I have disabled the backup of soft-linked directories at the job level and the global application level to determine if this has resolved the issue. NOTE: This is to a RALUS agent which has an NFS mount pointing to the data.

To get this log out of the Backup Exec RALUS Linux Agent, follow this article on how you can put the agent into debug mode, TECH35477. If you plan on contacting Symantec be sure that your operating system is supported, in our case RedHat Enterprise Linux 5.4 is the lastest supported RedHat Linux, in addition, know how to put the Linux Agent in debug mode and how to perform core dumps, TECH53188.

Leave a Reply